HTML Links in Gmail

Advert test
#1
I'm having a few problems getting html links to work in Gmail, I was wondering if anyone might have any tips? I've read that Gmail is particularly bad at rendering html. The links work fine if I remove the html... but then they don't show MS Outlook etc..
 
#2
Do you have a sample of the code you are using?
Gmail is pretty good with HTML. Are you sure the Rich Text editor option is turned on?
 
#3
Hi there, thanks for the reply.

I think I just got a bit muddled when testing the emails. I am sending out an automatic response to queries (well directory submissions to be more precise) and I have included a link. If I simply write www. somelink.com shows up on Gmail and Outlook. If I add <a href="http://www.somelink.com>www.somelink.com</a> it does not show up as a link on Gmail but does on Outlook. I think the conclusion (in this case) is not to add html.

Don't suppose anyone knows of any tutorials on coding for different email services/applications? I'm finding it a little confusing.

Andy
 
#5
Well I never had to link a page with code, so I did not face the problem. Normally the links go well without codes in both email and chats. But yes quite a few days ago, when I had to link two phrases, it worked alright. But it has been a year almost when I linked them.
 
#7
If I add <a href="http://www.somelink.com>www.somelink.com</a>

Did you copy paste this from the actual code? If you did, you have a missing double-quote there. Otherwise, did you check it with Firebug? I never had this kind of problems with Gmail, it was actually Outlook that was giving me headaches with HTML e-mails.
 
#8
This is going back a bit now, but in the end I figure the issue was to do with the conversational nature of Gmail. Because I had had been testing the email multiple times on the same email address I was not seeing some text and seeing "-show quoted text-" instead. Gmail figured I had seen the text already as part of the "conversation"... The problem would therefore not apply if I was sending the email to another address (presuming it was the first time I had sent the email).

So the problem was not actually a problem at all and had nothing to do with the HTML.
 
#10
If you go to the settings in gmail, then go to the signature you can add links through your signature. If you go through gmail labs you can also enable links. good luck mate!
 
Top