vbulletin login / pass reset issues - cookie issue?

Status
Not open for further replies.

mneylon

Administrator
Staff member
#1
Not sure if anyone else has run into this one, but thought I'd ask anyway ..

Upgraded a Vbulletin 3 board to vbulletin 4

I can login and out without any issue, as can anyone else that had an account

User reported issues earlier today and can't reset his login or gain access

I've created a test account and am having an identical issue

Could it be cookie related or is it likely to be something else?
 

mneylon

Administrator
Staff member
#2
Turns out the issue was due to the "salt" length in the "user" table
More details here: Forum 4.0.2 PL2 Password Reset Problem

Thanks to a friend for finding it!

Basically the upgrades ran on vbulletin as normal, but for some odd reason the upgrade_402_salt.php didn't get triggered, so the salt was left at 3 characters, when it should have been set to 30 ..
 

mneylon

Administrator
Staff member
#4
Another issue that is annoying. You log in, tick the remember me box but the sodding thing does not and every new day you have to log in again.
Has this only started happening since the upgrade?
Is it still happening?

I'm logged in currently from my home machine and it had maintained the cookie from last night
 

Dara

New Member
#5
Has this only started happening since the upgrade?
Is it still happening?

I'm logged in currently from my home machine and it had maintained the cookie from last night
I'm having the same issue-keep having to login and the box to tick Remember Me is very difficult to see under the banner ad. This is since the upgrade yes. On another issue and no idea if its connected to the upgrade but I suggested to a colleague to join the forum and he can't from either work or home PC. Keeps getting some sort of Blocked message-I can ask him exactly what the issue is and revert.
 

mneylon

Administrator
Staff member
#6
For the password issue - I'll do a bit of digging. I *think* that changing the cookie settings *might* fix it, but I'm going to check if other board owners have had a similar problem before I do anything ..

As for your friend - more info on their issue would be very helpful

thanks
 

Dara

New Member
#7
For the password issue - I'll do a bit of digging. I *think* that changing the cookie settings *might* fix it, but I'm going to check if other board owners have had a similar problem before I do anything ..

As for your friend - more info on their issue would be very helpful

thanks
Seems his IP is being blocked each time he tries to register. He has tried from both work and home and is with NTL if thats of use.
 
Status
Not open for further replies.
Award-winning Mac antivirus and Internet security software
Top