Zen Cart moving server issues

Status
Not open for further replies.
#1
Hi all

Im trying to move a zencart store to a new server. First time using it and its driving me nuts already. Ive copied over the database & all files and checked the config files. All urls look ok. Im getting this error though System Setup Required

Please someone help.Bugger all online.
 
#3
Well I did a fresh install and replaced everything with teh old site files, bar the config files so they should be correct. Incidentally the admin login is working fine. Just the main site isnt Ruby Couture.
 
#5
that is not the URL of your website and that could be the problem.
Not sure what you mean, can you clarify? Im using a temporary blacknight url. HAvent pointed tehdomain to it yet. Should make no difference. Correct me if im wrong Blacknight!
 

mneylon

Administrator
Staff member
#6
Not sure what you mean, can you clarify? Im using a temporary blacknight url. HAvent pointed tehdomain to it yet. Should make no difference. Correct me if im wrong Blacknight!
Disclaimer: I've never tried installing this particular script

*If* the paths are 100% corrrect ie. you have the full path set - ok
A lot of scripts will need to know the hostname / domain name / web address of the install. If you used the "real" domain instead of the temporary one this might cause issues - there are ways around that of course, but it's something I'd suspect
 

mneylon

Administrator
Staff member
#8
Hi BK. No I used the temp url on everything for now as the new domain isnt pointed yet. Im wondering is it permissions?
It might be .. As I said, I've never used that software, so I've no idea about its inner workings .. I'd recommend contacting our helpdesk via Livechat or email - they may be able to spot something that we've both missed (well - I haven't seen everything admittedly .. )
 
#9
Thanks mate. I think its more to do with zencart though. Ive submitted to the zencart forums anyway so will post the solution when/if i sort it.
 
#10
EggDesign.

Firstly check your /includes/configure.php to ensure:


define('HTTP_SERVER', 'http://d1099523-3.cp.blacknight.com/shop');
define('HTTPS_SERVER', 'https://d1099523-3.cp.blacknight.com/shop/');

You can change this to your "official" url when ready in the future.

2) Check that your .htaccess file is setup correctly. We always recommend to rename it to test.htaccess to move it out of the way while you are going through testing.

3) If you are getting any errors. Go to /includes/extra_configures/ and add a file

Name: enable_error_logging.php
Content:

<?php
/**
* enable_error_logging.php
* Tool for debugging hard-to-track-down issues
*
* @package utilities
* @copyright Copyright 2003-2008 Zen Cart Development Team
* @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
* @version $Id: enable_error_logging.php 7842 2008-01-05 07:54:38Z drbyte $
*/
/**
* HOW TO USE:
*
* 1. Specify the desired pages to do debugging on below. Leaving the default of '*' is usually fine.
* 2. Upload this file to the /includes/extra_configures/ folder.
* 3. Test the page on your site that is having problems -- ie: trigger whatever symptom is ailing you.
* 4. Open the /cache/myDEBUG-xxxxxxx.log folder to see the list of any PHP errors that occurred while the page/test was running.
* 5. Be sure to delete this file from the /includes/extra_configures folder when done (or rename it to .php1 instead of .php )
*/
/**
* Specify the pages you wish to enable debugging for (ie: main_page=xxxxxxxx)
* Using '*' will cause all pages to be enabled
*/
$pages_to_debug[] = '*';
$pages_to_debug[] = '';
$pages_to_debug[] = '';
$pages_to_debug[] = '';
$pages_to_debug[] = '';
$pages_to_debug[] = '';
$pages_to_debug[] = '';
$pages_to_debug[] = '';

/**
* The path where the debug log file will be located
* Default value is: DIR_FS_SQL_CACHE . '/myDEBUG-00000000.log'
* ... which puts it in the /cache/ folder: /cache/myDEBUG-00000000.log (where 0000000 is the server's timestamp)
*/
$debug_logfile_path = DIR_FS_SQL_CACHE . '/myDEBUG-' . time() . '.log';

/**
* Optional name for log file, which include random value characters, thus making it hard for hackers to snoop around by guessing filenames
*/
// $debug_logfile_path = DIR_FS_SQL_CACHE . '/myDEBUG-' . time() . zen_create_random_value(6) . '.log';

/**
* Error reporting level to log
* Default: E_ALL ^E_NOTICE
*/
$errors_to_log = E_ALL ^E_NOTICE;



///// DO NOT EDIT BELOW THIS LINE /////

//////////////////// DEBUG HANDLING //////////////////////////////////
if (in_array('*', $pages_to_debug) || in_array($current_page_base, $pages_to_debug)) {
/**
* Sometimes it is difficult to debug PHP background activities
* However, using the PHP error logging facility we can store all PHP errors to a file, and then review separately.
* Using this method, the debug details are stored at: /cache/myDEBUG.log
*/
@ini_set('log_errors', 1); // store to file
@ini_set('log_errors_max_len', 0); // unlimited length of message output
@ini_set('display_errors', 0); // do not output errors to screen/browser/client
@ini_set('error_log', $debug_logfile_path); // the filename
@ini_set('error_reporting', $errors_to_log ); // log only errors of more severity than NOTICE
}
?>
This will report any errors to your /cache folder.

Post your questions on here and I will try and help further.

Regards

Jamie
 
#11
Hi Jamie, thanks very much for that thorough reply. I actually got in touch with the original developer that worked on the site on his server (where I am moving it from) He managed to get the homepage up anyway somehow. Not sure what he did exactly. Will try to find out & post.

Thanks all for help
 
#15
"Well I did a fresh install and replaced everything with teh old site files, bar the config files so they should be correct. Incidentally the admin login is working fine. Just the main site went blank"

I have the exact same problem with moving my site, please tell me how was the procedure to resolve the problem?
 
Status
Not open for further replies.
Award-winning Mac antivirus and Internet security software
Top